{"action":"Upgrade notebook to 7.0.7 or later.","affected":[{"fixed":"7.0.7","introduced":"7.0.0"}],"component":"notebook","cve_ids":["CVE-2024-22420"],"ecosystem":"PyPI","epss":0.00573,"exploited":false,"fixed_versions":["7.0.7"],"ghsa_id":"GHSA-4m77-cmpx-vjc4","id":"tcs_01M5KGV6WWWX6HND7DSV17FBAB","modified_at":"2026-07-13T16:43:39.178881124Z","published_at":"2026-07-07T11:45:30.804450Z","references":["https://osv.dev/vulnerability/PYSEC-2026-1707","https://github.com/jupyterlab/jupyterlab/security/advisories/GHSA-4m77-cmpx-vjc4","https://nvd.nist.gov/vuln/detail/CVE-2024-22420","https://github.com/jupyterlab/jupyterlab/commit/dda0033cd49449572d077bbecd33b18d8d05f48a","https://github.com/jupyterlab/jupyterlab/commit/e1b3aabab603878e46add445a3114e838411d2df","https://github.com/jupyterlab/jupyterlab","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/UQJKNRDRFMKGVRIYNNN6CKMNJDNYWO2H","https://pypi.org/project/notebook","https://github.com/advisories/GHSA-4m77-cmpx-vjc4"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"PYSEC-2026-1707","url":"https://osv.dev/vulnerability/PYSEC-2026-1707"}],"summary":"JupyterLab vulnerable to SXSS in Markdown Preview"}