{"action":"Upgrade pgadmin4 to 8.5 or later.","affected":[{"fixed":"8.5","introduced":"0"}],"component":"pgadmin4","cve_ids":["CVE-2024-3116"],"ecosystem":"PyPI","epss":0.65815,"exploited":false,"fixed_versions":["8.5"],"ghsa_id":"GHSA-27jx-ffw8-xrqv","id":"tcs_01M5KGVJ2JSJN4931W21GG82WZ","modified_at":"2026-07-07T17:47:18.531354557Z","published_at":"2026-07-07T11:45:37.487467Z","references":["https://osv.dev/vulnerability/PYSEC-2026-1767","https://nvd.nist.gov/vuln/detail/CVE-2024-3116","https://github.com/pgadmin-org/pgadmin4/issues/7326","https://github.com/pgadmin-org/pgadmin4/commit/fbbbfe22dd468bcfef1e1f833ec32289a6e56a8b","https://gist.github.com/aelmokhtar/689a8be7e3bd535ec01992d8ec7b2b98","https://github.com/pgadmin-org/pgadmin4","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/GIF5T34JTTYRGIN5YPT366BDFG6452A2","https://www.vicarius.io/vsociety/posts/remote-code-execution-vulnerability-in-pgadmin-cve-2024-3116","https://pypi.org/project/pgadmin4","https://github.com/advisories/GHSA-27jx-ffw8-xrqv"],"severity":{"label":"high","score":7.4},"sources":[{"source":"osv","source_id":"PYSEC-2026-1767","url":"https://osv.dev/vulnerability/PYSEC-2026-1767"}],"summary":"pgAdmin Remote Code Execution (RCE) vulnerability"}