{"action":"Upgrade pgadmin4 to 8.6 or later.","affected":[{"fixed":"8.6","introduced":"0"}],"component":"pgadmin4","cve_ids":["CVE-2024-4216"],"ecosystem":"PyPI","epss":0.00461,"exploited":false,"fixed_versions":["8.6"],"ghsa_id":"GHSA-xv64-8p4r-94gq","id":"tcs_01M5KGVKQZ79AAZCG4KQAY75VT","modified_at":"2026-07-07T17:48:01.153034715Z","published_at":"2026-07-07T11:45:40.587232Z","references":["https://osv.dev/vulnerability/PYSEC-2026-1777","https://nvd.nist.gov/vuln/detail/CVE-2024-4216","https://github.com/pgadmin-org/pgadmin4/issues/7282","https://github.com/pgadmin-org/pgadmin4/commit/e384c9665ae2e72376be7cefa8e652efcee93767","https://github.com/pgadmin-org/pgadmin4","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/T2YFVCB4HCXU3FQBZ5XTWJZWSZUDNCXE","https://pypi.org/project/pgadmin4","https://github.com/advisories/GHSA-xv64-8p4r-94gq"],"severity":{"label":"high","score":7.4},"sources":[{"source":"osv","source_id":"PYSEC-2026-1777","url":"https://osv.dev/vulnerability/PYSEC-2026-1777"}],"summary":"pgAdmin Cross-site Scripting vulnerability in /settings/store API response json payload"}