{"action":"Upgrade red-discordbot to 3.5.10 or later.","affected":[{"fixed":"3.5.10","introduced":"3.5.0"}],"component":"red-discordbot","cve_ids":["CVE-2024-39905"],"ecosystem":"PyPI","epss":0.00413,"exploited":false,"fixed_versions":["3.5.10"],"ghsa_id":"GHSA-5jq8-q6rj-9gq4","id":"tcs_01M5KGW4Y8M1GRRMD27G6FQJ6Z","modified_at":"2026-07-07T17:47:00.815776908Z","published_at":"2026-07-07T14:34:36.672478Z","references":["https://osv.dev/vulnerability/PYSEC-2026-1865","https://github.com/Cog-Creators/Red-DiscordBot/security/advisories/GHSA-5jq8-q6rj-9gq4","https://nvd.nist.gov/vuln/detail/CVE-2024-39905","https://github.com/Cog-Creators/Red-DiscordBot/pull/6398","https://github.com/Cog-Creators/Red-DiscordBot/commit/0b0b23b9717b40ed4f8715720b199417c8e89750","https://github.com/Cog-Creators/Red-DiscordBot","https://pypi.org/project/red-discordbot","https://github.com/advisories/GHSA-5jq8-q6rj-9gq4"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"PYSEC-2026-1865","url":"https://osv.dev/vulnerability/PYSEC-2026-1865"}],"summary":"Red-DiscordBot vulnerable to Incorrect Authorization in commands API"}