{"action":"Upgrade requests to 2.32.0 or later.","affected":[{"fixed":"2.32.0","introduced":"0"}],"component":"requests","cve_ids":["CVE-2024-35195"],"ecosystem":"PyPI","epss":0.0034,"exploited":false,"fixed_versions":["2.32.0"],"ghsa_id":"GHSA-9wx4-h78v-vm56","id":"tcs_01M5KGW6ARCNEZFNSSKV6NKJXH","modified_at":"2026-07-07T17:46:36.762141019Z","published_at":"2026-07-07T11:45:42.890131Z","references":["https://osv.dev/vulnerability/PYSEC-2026-1873","https://github.com/psf/requests/security/advisories/GHSA-9wx4-h78v-vm56","https://nvd.nist.gov/vuln/detail/CVE-2024-35195","https://github.com/psf/requests/pull/6655","https://github.com/psf/requests/commit/a58d7f2ffb4d00b46dca2d70a3932a0b37e22fac","https://github.com/psf/requests","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/IYLSNK5TL46Q6XPRVMHVWS63MVJQOK4Q","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/N7WP6EYDSUOCOJYHDK5NX43PYZ4SNHGZ","https://pypi.org/project/requests","https://github.com/advisories/GHSA-9wx4-h78v-vm56"],"severity":{"label":"medium","score":5.6},"sources":[{"source":"osv","source_id":"PYSEC-2026-1873","url":"https://osv.dev/vulnerability/PYSEC-2026-1873"}],"summary":"Requests `Session` object does not verify requests after making first request with verify=False"}