{"action":"Upgrade setuptools to 70.0.0 or later.","affected":[{"fixed":"70.0.0","introduced":"0"}],"component":"setuptools","cve_ids":["CVE-2024-6345"],"ecosystem":"PyPI","epss":0.01939,"exploited":false,"fixed_versions":["70.0.0"],"ghsa_id":"GHSA-cx63-2mw6-8hw5","id":"tcs_01M5KGWESYTA0C49VCG9K78EKY","modified_at":"2026-07-07T17:57:13.326243614Z","published_at":"2026-07-07T14:34:36.817041Z","references":["https://osv.dev/vulnerability/PYSEC-2026-1918","https://nvd.nist.gov/vuln/detail/CVE-2024-6345","https://github.com/pypa/setuptools/pull/4332","https://github.com/pypa/setuptools/commit/88807c7062788254f654ea8c03427adc859321f0","https://github.com/pypa/setuptools","https://huntr.com/bounties/d6362117-ad57-4e83-951f-b8141c6e7ca5","https://lists.debian.org/debian-lts-announce/2024/09/msg00018.html","https://pypi.org/project/setuptools","https://github.com/advisories/GHSA-cx63-2mw6-8hw5"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"PYSEC-2026-1918","url":"https://osv.dev/vulnerability/PYSEC-2026-1918"}],"summary":"setuptools vulnerable to Command Injection via package URL"}