{"action":"Upgrade sglang to 0.5.4 or later.","affected":[{"fixed":"0.5.4","introduced":"0"}],"component":"sglang","cve_ids":["CVE-2025-10164"],"ecosystem":"PyPI","epss":0.00408,"exploited":false,"fixed_versions":["0.5.4"],"ghsa_id":"GHSA-9w53-xr52-mwgj","id":"tcs_01M5KGWEZ0ZGX2B67SQMD3F92E","modified_at":"2026-07-07T17:48:10.269625963Z","published_at":"2026-07-07T16:03:04.360123Z","references":["https://osv.dev/vulnerability/PYSEC-2026-1919","https://nvd.nist.gov/vuln/detail/CVE-2025-10164","https://github.com/sgl-project/sglang/commit/49afb3d9d9deedf6dea3a6dd5c50e85e7d8bcb07","https://github.com/sgl-project/sglang","https://vuldb.com/?ctiid.323203","https://vuldb.com/?id.323203","https://vuldb.com/?submit.635919","https://pypi.org/project/sglang","https://github.com/advisories/GHSA-9w53-xr52-mwgj"],"severity":{"label":"high","score":7.3},"sources":[{"source":"osv","source_id":"PYSEC-2026-1919","url":"https://osv.dev/vulnerability/PYSEC-2026-1919"}],"summary":"SGLang Remote Code Execution Vulnerability via Unsafe Deserialization in update_weights_from_tensor"}