{"action":"Upgrade spotipy to 2.25.2 or later.","affected":[{"fixed":"2.25.2","introduced":"0"}],"component":"spotipy","cve_ids":["CVE-2025-66040"],"ecosystem":"PyPI","epss":0.00166,"exploited":false,"fixed_versions":["2.25.2"],"ghsa_id":"GHSA-r77h-rpp9-w2xm","id":"tcs_01M5KGWJ8ZWA02W44ZQSYQF7J1","modified_at":"2026-07-07T17:47:58.766812649Z","published_at":"2026-07-07T16:03:11.611342Z","references":["https://osv.dev/vulnerability/PYSEC-2026-1937","https://github.com/spotipy-dev/spotipy/security/advisories/GHSA-r77h-rpp9-w2xm","https://nvd.nist.gov/vuln/detail/CVE-2025-66040","https://github.com/spotipy-dev/spotipy/commit/880b92d7243dcf2b83bf31dc365a858d8b5e6767","https://github.com/spotipy-dev/spotipy","https://pypi.org/project/spotipy","https://github.com/advisories/GHSA-r77h-rpp9-w2xm"],"severity":{"label":"low","score":3.6},"sources":[{"source":"osv","source_id":"PYSEC-2026-1937","url":"https://osv.dev/vulnerability/PYSEC-2026-1937"}],"summary":"Spotipy has a XSS vulnerability in its OAuth callback server"}