{"action":"Upgrade tensorflow-gpu to 2.12.1 or later.","affected":[{"fixed":"2.12.1","introduced":"0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2023-33976"],"ecosystem":"PyPI","epss":0.00432,"exploited":false,"fixed_versions":["2.12.1"],"ghsa_id":"GHSA-gjh7-xx4r-x345","id":"tcs_01M5KGWPV3ZZ6Z9DF2MPAZTXSK","modified_at":"2026-07-13T16:43:08.886917273Z","published_at":"2026-07-07T14:34:37.928257Z","references":["https://osv.dev/vulnerability/PYSEC-2026-1962","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-gjh7-xx4r-x345","https://nvd.nist.gov/vuln/detail/CVE-2023-33976","https://github.com/tensorflow/tensorflow/commit/6fa05df43b00038b048f4f0e51ef522da6532fec","https://github.com/tensorflow/tensorflow/commit/915884fdf5df34aaedd00fc6ace33a2cfdefa586","https://github.com/tensorflow/tensorflow","https://pypi.org/project/tensorflow-gpu","https://github.com/advisories/GHSA-gjh7-xx4r-x345"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"PYSEC-2026-1962","url":"https://osv.dev/vulnerability/PYSEC-2026-1962"}],"summary":"TensorFlow has segfault in array_ops.upper_bound"}