{"action":"Upgrade vllm to 0.11.0 or later.","affected":[{"fixed":"0.11.0","introduced":"0.5.0"}],"component":"vllm","cve_ids":["CVE-2025-6242"],"ecosystem":"PyPI","epss":0.00253,"exploited":false,"fixed_versions":["0.11.0"],"ghsa_id":"GHSA-3f6c-7fw2-ppm4","id":"tcs_01M5KGWZNYVE2FJGFRTFX0DPJQ","modified_at":"2026-07-07T17:47:19.654040812Z","published_at":"2026-07-07T16:03:06.992470Z","references":["https://osv.dev/vulnerability/PYSEC-2026-2011","https://github.com/vllm-project/vllm/security/advisories/GHSA-3f6c-7fw2-ppm4","https://nvd.nist.gov/vuln/detail/CVE-2025-6242","https://github.com/vllm-project/vllm/commit/9d9a2b77f19f68262d5e469c4e82c0f6365ad72d","https://access.redhat.com/security/cve/CVE-2025-6242","https://bugzilla.redhat.com/show_bug.cgi?id=2373716","https://github.com/vllm-project/vllm","https://pypi.org/project/vllm","https://github.com/advisories/GHSA-3f6c-7fw2-ppm4"],"severity":{"label":"high","score":7.1},"sources":[{"source":"osv","source_id":"PYSEC-2026-2011","url":"https://osv.dev/vulnerability/PYSEC-2026-2011"}],"summary":"vLLM is vulnerable to Server-Side Request Forgery (SSRF) through `MediaConnector` class"}