{"action":"Upgrade vllm to 0.10.1.1 or later.","affected":[{"fixed":"0.10.1.1","introduced":"0.10.0"}],"component":"vllm","cve_ids":["CVE-2025-9141"],"ecosystem":"PyPI","exploited":false,"fixed_versions":["0.10.1.1"],"ghsa_id":"GHSA-79j6-g2m3-jgfw","id":"tcs_01M5KGX05NHGFW7JGPRFQ9E6X8","modified_at":"2026-07-07T17:47:20.258477795Z","published_at":"2026-07-07T16:03:01.633632Z","references":["https://osv.dev/vulnerability/PYSEC-2026-2014","https://github.com/vllm-project/vllm/security/advisories/GHSA-79j6-g2m3-jgfw","https://github.com/vllm-project/vllm/pull/21396","https://github.com/vllm-project/vllm/commit/4594fc3b281713bd3d7634405b4a1393af40d294","https://github.com/vllm-project/vllm","https://pypi.org/project/vllm","https://github.com/advisories/GHSA-79j6-g2m3-jgfw","https://nvd.nist.gov/vuln/detail/CVE-2025-9141"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"PYSEC-2026-2014","url":"https://osv.dev/vulnerability/PYSEC-2026-2014"}],"summary":"vLLM has remote code execution vulnerability in the tool call parser for Qwen3-Coder"}