{"action":"Upgrade vllm to 0.14.1 or later.","affected":[{"fixed":"0.14.1","introduced":"0"}],"component":"vllm","cve_ids":["CVE-2026-24779"],"ecosystem":"PyPI","epss":0.00579,"exploited":false,"fixed_versions":["0.14.1"],"ghsa_id":"GHSA-qh4c-xf7m-gxfc","id":"tcs_01M5KGX1FGC8F488QV96054VJM","modified_at":"2026-07-07T17:48:17.166307643Z","published_at":"2026-07-07T16:03:20.898386Z","references":["https://osv.dev/vulnerability/PYSEC-2026-2020","https://github.com/vllm-project/vllm/security/advisories/GHSA-qh4c-xf7m-gxfc","https://nvd.nist.gov/vuln/detail/CVE-2026-24779","https://github.com/vllm-project/vllm/pull/32746","https://github.com/vllm-project/vllm/commit/f46d576c54fb8aeec5fc70560e850bed38ef17d7","https://github.com/vllm-project/vllm","https://pypi.org/project/vllm","https://github.com/advisories/GHSA-qh4c-xf7m-gxfc"],"severity":{"label":"high","score":7.1},"sources":[{"source":"osv","source_id":"PYSEC-2026-2020","url":"https://osv.dev/vulnerability/PYSEC-2026-2020"}],"summary":"vLLM vulnerable to Server-Side Request Forgery (SSRF) through MediaConnector"}