{"action":"Upgrade vllm to 0.10.1.1 or later.","affected":[{"fixed":"0.10.1.1","introduced":"0.1.0"}],"component":"vllm","cve_ids":["CVE-2025-48956"],"ecosystem":"PyPI","epss":0.00565,"exploited":false,"fixed_versions":["0.10.1.1"],"ghsa_id":"GHSA-rxc4-3w6r-4v47","id":"tcs_01M5KGX1MG7FYJMM3TK0QPYA4M","modified_at":"2026-07-07T17:48:17.626607221Z","published_at":"2026-07-07T16:03:01.559740Z","references":["https://osv.dev/vulnerability/PYSEC-2026-2021","https://github.com/vllm-project/vllm/security/advisories/GHSA-rxc4-3w6r-4v47","https://nvd.nist.gov/vuln/detail/CVE-2025-48956","https://github.com/vllm-project/vllm/pull/23267","https://github.com/vllm-project/vllm/commit/d8b736f913a59117803d6701521d2e4861701944","https://github.com/vllm-project/vllm","https://pypi.org/project/vllm","https://github.com/advisories/GHSA-rxc4-3w6r-4v47"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"PYSEC-2026-2021","url":"https://osv.dev/vulnerability/PYSEC-2026-2021"}],"summary":"vllm API endpoints vulnerable to Denial of Service Attacks"}