{"action":"Upgrade wagtail to 6.0.5 or later.","affected":[{"fixed":"6.0.5","introduced":"6.0.0"},{"fixed":"6.1.2","introduced":"6.1.0"}],"component":"wagtail","cve_ids":["CVE-2024-35228"],"ecosystem":"PyPI","epss":0.00332,"exploited":false,"fixed_versions":["6.0.5","6.1.2"],"ghsa_id":"GHSA-xxfm-vmcf-g33f","id":"tcs_01M5KGX3BEEGKMBE6NB4QQWEJK","modified_at":"2026-07-07T17:46:23.966113373Z","published_at":"2026-07-07T11:45:44.164164Z","references":["https://osv.dev/vulnerability/PYSEC-2026-2032","https://github.com/wagtail/wagtail/security/advisories/GHSA-xxfm-vmcf-g33f","https://nvd.nist.gov/vuln/detail/CVE-2024-35228","https://github.com/wagtail/wagtail/commit/284f75a6f91f7ab18cc304d7d34f33b559ae37b1","https://github.com/wagtail/wagtail","https://pypi.org/project/wagtail","https://github.com/advisories/GHSA-xxfm-vmcf-g33f"],"severity":{"label":"medium","score":5.5},"sources":[{"source":"osv","source_id":"PYSEC-2026-2032","url":"https://osv.dev/vulnerability/PYSEC-2026-2032"}],"summary":"Improper Handling of Insufficient Permissions in `wagtail.contrib.settings`"}