{"action":"Upgrade weave to 0.50.8 or later.","affected":[{"fixed":"0.50.8","introduced":"0"}],"component":"weave","cve_ids":["CVE-2024-7340"],"ecosystem":"PyPI","epss":0.05015,"exploited":false,"fixed_versions":["0.50.8"],"ghsa_id":"GHSA-r49h-6qxq-624f","id":"tcs_01M5KGX3SHPMF9N66G45JMZKT5","modified_at":"2026-07-07T17:46:23.961608143Z","published_at":"2026-07-07T14:34:38.008803Z","references":["https://osv.dev/vulnerability/PYSEC-2026-2035","https://nvd.nist.gov/vuln/detail/CVE-2024-7340","https://github.com/wandb/weave/pull/1657","https://github.com/wandb/weave/commit/f43d5fb75e0d52933a52ecd9a0ce2f9b082e6c9f","https://github.com/wandb/weave","https://research.jfrog.com/vulnerabilities/wandb-weave-server-remote-arbitrary-file-leak-jfsa-2024-001039248","https://pypi.org/project/weave","https://github.com/advisories/GHSA-r49h-6qxq-624f"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"PYSEC-2026-2035","url":"https://osv.dev/vulnerability/PYSEC-2026-2035"}],"summary":"Weave server API vulnerable to arbitrary file leak"}