{"action":"Upgrade zenml to 0.42.2 or later.","affected":[{"fixed":"0.42.2","introduced":"0"},{"fixed":"0.43.1","introduced":"0.43.0"},{"fixed":"0.44.4","introduced":"0.44.0"},{"fixed":"0.46.7","introduced":"0.45.0"}],"component":"zenml","cve_ids":["CVE-2024-25723"],"ecosystem":"PyPI","epss":0.70785,"exploited":false,"fixed_versions":["0.42.2","0.43.1","0.44.4","0.46.7"],"ghsa_id":"GHSA-vf7j-cmrj-pmmm","id":"tcs_01M5KGXAM82TTY0S2W1H6W7RNB","modified_at":"2026-07-07T17:48:17.217196302Z","published_at":"2026-07-07T11:45:33.016802Z","references":["https://osv.dev/vulnerability/PYSEC-2026-2072","https://nvd.nist.gov/vuln/detail/CVE-2024-25723","https://github.com/zenml-io/zenml","https://github.com/zenml-io/zenml/compare/0.42.1...0.42.2","https://github.com/zenml-io/zenml/compare/0.43.0...0.43.1","https://github.com/zenml-io/zenml/compare/0.44.3...0.44.4","https://www.zenml.io/blog/critical-security-update-for-zenml-users","https://pypi.org/project/zenml","https://github.com/advisories/GHSA-vf7j-cmrj-pmmm"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"PYSEC-2026-2072","url":"https://osv.dev/vulnerability/PYSEC-2026-2072"}],"summary":"ZenML Server Remote Privilege Escalation Vulnerability"}