{"action":"Upgrade glances to 4.5.4 or later.","affected":[{"fixed":"4.5.4","introduced":"0"}],"component":"glances","cve_ids":["CVE-2026-35587"],"ecosystem":"PyPI","epss":0.00396,"exploited":false,"fixed_versions":["4.5.4"],"ghsa_id":"GHSA-g5pq-48mj-jvw8","id":"tcs_01M5KGXX16QKRCVEG5C3YFNDNX","modified_at":"2026-07-13T07:15:32.865376138Z","published_at":"2026-04-21T00:16:29.030Z","references":["https://osv.dev/vulnerability/PYSEC-2026-2176","https://github.com/nicolargo/glances/commit/d6808be66728956477cc4b544bab1acd71ac65fb","https://github.com/nicolargo/glances/security/advisories/GHSA-g5pq-48mj-jvw8"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"PYSEC-2026-2176","url":"https://osv.dev/vulnerability/PYSEC-2026-2176"}],"summary":"Glances is an open-source system cross-platform monitoring tool. Prior to version 4.5.4, a Server-Side Request Forgery (SSRF) vulnerability exists in the Glances IP plugin due to improper validation o"}