{"action":"Upgrade jupyter-server to 2.18.0 or later.","affected":[{"fixed":"2.18.0","introduced":"0"}],"component":"jupyter-server","cve_ids":["CVE-2026-40110"],"ecosystem":"PyPI","epss":0.00313,"exploited":false,"fixed_versions":["2.18.0"],"ghsa_id":"GHSA-24qx-w28j-9m6p","id":"tcs_01M5KGXYZT0H0JT7JMNDPNXCRN","modified_at":"2026-07-13T07:15:34.116347312Z","published_at":"2026-05-05T22:16:00.663Z","references":["https://osv.dev/vulnerability/PYSEC-2026-2187","https://access.redhat.com/security/cve/CVE-2026-40110","https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-40110.json","https://bugzilla.redhat.com/show_bug.cgi?id=2466912","https://github.com/jupyter-server/jupyter_server/pull/603","https://github.com/jupyter-server/jupyter_server/commit/057869a327c46730afede3eab0ca2d2e3e74acea","https://github.com/jupyter-server/jupyter_server/commit/49b34392feaa97735b3b777e3baf8f22f2a14ed8","https://github.com/jupyter-server/jupyter_server/security/advisories/GHSA-24qx-w28j-9m6p"],"severity":{"label":"high","score":7.3},"sources":[{"source":"osv","source_id":"PYSEC-2026-2187","url":"https://osv.dev/vulnerability/PYSEC-2026-2187"}],"summary":"Jupyter Server is the backend for Jupyter web applications. In versions 2.17.0 and earlier, the Origin header validation uses Python's re.match() to check incoming origins against the allow_origin_pat"}