{"action":"Upgrade jupyterhub to 5.4.5 or later.","affected":[{"fixed":"5.4.5","introduced":"4.1.0"}],"component":"jupyterhub","cve_ids":["CVE-2026-40864"],"ecosystem":"PyPI","epss":0.00146,"exploited":false,"fixed_versions":["5.4.5"],"ghsa_id":"GHSA-m68r-v472-jgq9","id":"tcs_01M5KGXZ9RYSBW04H975NWCVCZ","modified_at":"2026-07-13T07:26:16.328743594Z","published_at":"2026-05-22T21:16:43.177Z","references":["https://osv.dev/vulnerability/PYSEC-2026-2189","https://github.com/jupyterhub/jupyterhub/security/advisories/GHSA-m68r-v472-jgq9","https://github.com/jupyterhub/jupyterhub/commit/9c5ec277d3cda5a59de2d8c8117efa77bd941127"],"severity":{"label":"medium","score":4.3},"sources":[{"source":"osv","source_id":"PYSEC-2026-2189","url":"https://osv.dev/vulnerability/PYSEC-2026-2189"}],"summary":"JupyterHub is software that allows users to create a multi-user server for Jupyter notebooks. In versions 4.1.0 through 5.4.4, XSRF protection (updated in 4.1.0) inappropriately treated requests with"}