{"action":"Upgrade langchain-core to 1.2.22 or later.","affected":[{"fixed":"1.2.22","introduced":"0"}],"component":"langchain-core","cve_ids":["CVE-2026-34070"],"ecosystem":"PyPI","epss":0.01382,"exploited":false,"fixed_versions":["1.2.22"],"ghsa_id":"GHSA-qh6h-p6c9-ff54","id":"tcs_01M5KGY0C7XDMY35N8BA96PYDS","modified_at":"2026-07-13T07:15:26.389701816Z","published_at":"2026-03-31T03:15:58.947Z","references":["https://osv.dev/vulnerability/PYSEC-2026-2193","https://access.redhat.com/security/cve/CVE-2026-34070","https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-34070.json","https://access.redhat.com/errata/RHSA-2026:24766","https://access.redhat.com/errata/RHSA-2026:37275","https://github.com/langchain-ai/langchain/releases/tag/langchain-core==1.2.22","https://bugzilla.redhat.com/show_bug.cgi?id=2453287","https://github.com/langchain-ai/langchain/commit/27add913474e01e33bededf4096151130ba0d47c","https://github.com/langchain-ai/langchain/security/advisories/GHSA-qh6h-p6c9-ff54"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"PYSEC-2026-2193","url":"https://osv.dev/vulnerability/PYSEC-2026-2193"}],"summary":"LangChain is a framework for building agents and LLM-powered applications. Prior to version 1.2.22, multiple functions in langchain_core.prompts.loading read files from paths embedded in deserialized"}