{"action":"Upgrade langgraph to 0.3.15 or later.","affected":[{"fixed":"0.3.15","introduced":"0"}],"component":"langgraph","cve_ids":["CVE-2026-48776"],"ecosystem":"PyPI","epss":0.00216,"exploited":false,"fixed_versions":["0.3.15"],"ghsa_id":"GHSA-w39p-vh2g-g8g5","id":"tcs_01M5KGY0HG8CG9QEBDEYJYW186","modified_at":"2026-07-13T16:42:27.619863658Z","published_at":"2026-06-17T10:55:15.113Z","references":["https://osv.dev/vulnerability/PYSEC-2026-2194","https://github.com/langchain-ai/langgraph/releases/tag/sdk%3D%3D0.3.15","https://github.com/langchain-ai/langgraph/security/advisories/GHSA-w39p-vh2g-g8g5"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"PYSEC-2026-2194","url":"https://osv.dev/vulnerability/PYSEC-2026-2194"}],"summary":"LangGraph Python SDK is used to connect to running LangGraph API servers, manage assistants, threads and stream runs from Python applications. Versions 0.3.14 and prior have unsafe URL path constructi"}