{"action":"Upgrade mlflow to 3.11.0 or later.","affected":[{"fixed":"3.11.0","introduced":"0"}],"component":"mlflow","cve_ids":["CVE-2026-4035"],"ecosystem":"PyPI","epss":0.00521,"exploited":false,"fixed_versions":["3.11.0"],"ghsa_id":"GHSA-g35p-px32-whv6","id":"tcs_01M5KGY6DBSADAKPTPT418M2S6","modified_at":"2026-07-13T16:45:04.877817766Z","published_at":"2026-06-03T09:16:13.083Z","references":["https://osv.dev/vulnerability/PYSEC-2026-2222","https://access.redhat.com/security/cve/CVE-2026-4035","https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-4035.json","https://bugzilla.redhat.com/show_bug.cgi?id=2484318","https://github.com/mlflow/mlflow/commit/4a3f2f720cb4f058c9e0c5b883e0acc9ab64a7f3","https://huntr.com/bounties/f8e591a0-0f19-4910-b82e-16c9956f2233","https://github.com/advisories/GHSA-g35p-px32-whv6"],"severity":{"label":"high","score":7.7},"sources":[{"source":"osv","source_id":"PYSEC-2026-2222","url":"https://osv.dev/vulnerability/PYSEC-2026-2222"}],"summary":"A vulnerability in mlflow/mlflow versions prior to 3.11.0 allows for the resolution of environment variables in AI Gateway secrets, which can be exploited to exfiltrate sensitive server-side environme"}