{"action":"Upgrade vllm to 0.22.0 or later.","affected":[{"fixed":"0.22.0","introduced":"0.3.0"}],"component":"vllm","cve_ids":["CVE-2026-48746"],"ecosystem":"PyPI","epss":0.01152,"exploited":false,"fixed_versions":["0.22.0"],"ghsa_id":"GHSA-94f4-hr76-p5j6","id":"tcs_01M5KGYD389AH141MBSX86JGYM","modified_at":"2026-06-26T00:00:06.010479511Z","published_at":"2026-06-22T23:16:30.490Z","references":["https://osv.dev/vulnerability/PYSEC-2026-226","https://github.com/vllm-project/vllm/security/advisories/GHSA-94f4-hr76-p5j6","https://x41-dsec.de/lab/advisories/x41-2026-002-starlette","https://github.com/vllm-project/vllm/pull/43426"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"PYSEC-2026-226","url":"https://osv.dev/vulnerability/PYSEC-2026-226"}],"summary":"vLLM is an inference and serving engine for large language models (LLMs). From 0.3.0 until 0.22.0, a vulnerability in ASGI web servers and starlette's trust on those web servers enables an authenticat"}