{"action":"Upgrade poetry to 2.3.3 or later.","affected":[{"fixed":"2.3.3","introduced":"1.4.0"}],"component":"poetry","cve_ids":["CVE-2026-34591"],"ecosystem":"PyPI","epss":0.00486,"exploited":false,"fixed_versions":["2.3.3"],"ghsa_id":"GHSA-2599-h6xx-hpxp","id":"tcs_01M5KGYD8B96PKBXVH9H6J0BHR","modified_at":"2026-07-13T07:15:36.423234295Z","published_at":"2026-04-02T18:16:31.163Z","references":["https://osv.dev/vulnerability/PYSEC-2026-2260","https://github.com/python-poetry/poetry/releases/tag/2.3.3","http://github.com/python-poetry/poetry/commit/ed59537ac3709cfbdbf95d957de801c13872991a","https://github.com/python-poetry/poetry/pull/10792","https://github.com/python-poetry/poetry/security/advisories/GHSA-2599-h6xx-hpxp"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"PYSEC-2026-2260","url":"https://osv.dev/vulnerability/PYSEC-2026-2260"}],"summary":"Poetry is a dependency manager for Python. From version 1.4.0 to before version 2.3.3, a crafted wheel can contain ../ paths that Poetry writes to disk without containment checks, allowing arbitrary f"}