{"action":"Upgrade psd-tools to 1.12.2 or later.","affected":[{"fixed":"1.12.2","introduced":"0"}],"component":"psd-tools","cve_ids":["CVE-2026-27809"],"ecosystem":"PyPI","epss":0.0048,"exploited":false,"fixed_versions":["1.12.2"],"ghsa_id":"GHSA-24p2-j2jr-386w","id":"tcs_01M5KGYDJC3NF9P32PJ0NY4YVE","modified_at":"2026-07-13T07:15:40.078708735Z","published_at":"2026-02-26T00:16:26.233Z","references":["https://osv.dev/vulnerability/PYSEC-2026-2262","https://github.com/psd-tools/psd-tools/releases/tag/v1.12.2","https://github.com/psd-tools/psd-tools/commit/6c0a78f195b5942757886a1863793fd5946c1fb1","https://github.com/psd-tools/psd-tools/security/advisories/GHSA-24p2-j2jr-386w"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"PYSEC-2026-2262","url":"https://osv.dev/vulnerability/PYSEC-2026-2262"}],"summary":"psd-tools is a Python package for working with Adobe Photoshop PSD files. Prior to version 1.12.2, when a PSD file contains malformed RLE-compressed image data (e.g. a literal run that extends past th"}