{"action":"Upgrade pyasn1 to 0.6.3 or later.","affected":[{"fixed":"0.6.3","introduced":"0"}],"component":"pyasn1","cve_ids":["CVE-2026-30922"],"ecosystem":"PyPI","epss":0.00817,"exploited":false,"fixed_versions":["0.6.3"],"ghsa_id":"GHSA-jr27-m4p2-rc6r","id":"tcs_01M5KGYDPZQ8WM1R52Q4SR8C48","modified_at":"2026-07-13T07:15:40.277367904Z","published_at":"2026-03-18T04:17:18.397Z","references":["https://osv.dev/vulnerability/PYSEC-2026-2263","http://www.openwall.com/lists/oss-security/2026/03/20/4","https://lists.debian.org/debian-lts-announce/2026/05/msg00001.html","https://github.com/pyasn1/pyasn1/commit/25ad481c19fdb006e20485ef3fc2e5b3eff30ef0","https://github.com/pyasn1/pyasn1/security/advisories/GHSA-jr27-m4p2-rc6r"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"PYSEC-2026-2263","url":"https://osv.dev/vulnerability/PYSEC-2026-2263"}],"summary":"pyasn1 is a generic ASN.1 library for Python. Prior to 0.6.3, the `pyasn1` library is vulnerable to a Denial of Service (DoS) attack caused by uncontrolled recursion when decoding ASN.1 data with deep"}