{"action":"Upgrade vllm to 0.22.1 or later.","affected":[{"fixed":"0.22.1","introduced":"0"}],"component":"vllm","cve_ids":["CVE-2026-54232"],"ecosystem":"PyPI","epss":0.00563,"exploited":false,"fixed_versions":["0.22.1"],"ghsa_id":"GHSA-jrf6-vqxq-pjv2","id":"tcs_01M5KGYEZSN4TYGJ7WT8HGS5Y7","modified_at":"2026-06-26T00:00:06.054142968Z","published_at":"2026-06-22T23:16:30.873Z","references":["https://osv.dev/vulnerability/PYSEC-2026-227","https://github.com/vllm-project/vllm/security/advisories/GHSA-jrf6-vqxq-pjv2"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"PYSEC-2026-227","url":"https://osv.dev/vulnerability/PYSEC-2026-227"}],"summary":"vLLM is an inference and serving engine for large language models (LLMs). Prior to 0.22.1, the vLLM Dockerfile is vulnerable to a dependency confusion attack through the flashinfer-jit-cache package."}