{"action":"Upgrade vllm to 0.18.0 or later.","affected":[{"fixed":"0.18.0","introduced":"0.10.1"}],"component":"vllm","cve_ids":["CVE-2026-27893"],"ecosystem":"PyPI","epss":0.01369,"exploited":false,"fixed_versions":["0.18.0"],"ghsa_id":"GHSA-7972-pg2x-xr59","id":"tcs_01M5KGYM4PZZW4ZVS0DB8EWTRF","modified_at":"2026-07-13T07:15:12.555154789Z","published_at":"2026-03-27T00:16:22.333Z","references":["https://osv.dev/vulnerability/PYSEC-2026-2297","https://access.redhat.com/security/cve/CVE-2026-27893","https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-27893.json","https://access.redhat.com/errata/RHSA-2026:10140","https://access.redhat.com/errata/RHSA-2026:10141","https://access.redhat.com/errata/RHSA-2026:19712","https://access.redhat.com/errata/RHSA-2026:19724","https://access.redhat.com/errata/RHSA-2026:19725","https://access.redhat.com/errata/RHSA-2026:24977","https://access.redhat.com/errata/RHSA-2026:37275","https://access.redhat.com/errata/RHSA-2026:8746","https://access.redhat.com/errata/RHSA-2026:8747","https://access.redhat.com/errata/RHSA-2026:8748","https://github.com/vllm-project/vllm/security/advisories/GHSA-7972-pg2x-xr59","https://bugzilla.redhat.com/show_bug.cgi?id=2452055","https://github.com/vllm-project/vllm/pull/36192","https://github.com/vllm-project/vllm/commit/00bd08edeee5dd4d4c13277c0114a464011acf72"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"PYSEC-2026-2297","url":"https://osv.dev/vulnerability/PYSEC-2026-2297"}],"summary":"vLLM is an inference and serving engine for large language models (LLMs). Starting in version 0.10.1 and prior to version 0.18.0, two model implementation files hardcode `trust_remote_code=True` when"}