{"action":"Upgrade vllm to 0.19.0 or later.","affected":[{"fixed":"0.19.0","introduced":"0.1.0"}],"component":"vllm","cve_ids":["CVE-2026-34756"],"ecosystem":"PyPI","epss":0.00421,"exploited":false,"fixed_versions":["0.19.0"],"ghsa_id":"GHSA-3mwp-wvh9-7528","id":"tcs_01M5KGYM9MG2KA8EDMN0YQ2RZN","modified_at":"2026-07-13T07:15:12.502269986Z","published_at":"2026-04-06T16:16:36.610Z","references":["https://osv.dev/vulnerability/PYSEC-2026-2298","https://access.redhat.com/security/cve/CVE-2026-34756","https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-34756.json","https://access.redhat.com/errata/RHSA-2026:36005","https://access.redhat.com/errata/RHSA-2026:36006","https://bugzilla.redhat.com/show_bug.cgi?id=2455425","https://github.com/vllm-project/vllm/commit/b111f8a61f100fdca08706f41f29ef3548de7380","https://github.com/vllm-project/vllm/pull/37952","https://github.com/vllm-project/vllm/security/advisories/GHSA-3mwp-wvh9-7528"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"PYSEC-2026-2298","url":"https://osv.dev/vulnerability/PYSEC-2026-2298"}],"summary":"vLLM is an inference and serving engine for large language models (LLMs). From 0.1.0 to before 0.19.0, a Denial of Service vulnerability exists in the vLLM OpenAI-compatible API server. Due to the lac"}