{"action":"Upgrade vllm to 0.22.0 or later.","affected":[{"fixed":"0.22.0","introduced":"0"}],"component":"vllm","cve_ids":["CVE-2026-41523"],"ecosystem":"PyPI","epss":0.00913,"exploited":false,"fixed_versions":["0.22.0"],"ghsa_id":"GHSA-q8gq-377p-jq3r","id":"tcs_01M5KGYMX4B4A3NN63D6N3KSW9","modified_at":"2026-07-13T07:15:12.552873453Z","published_at":"2026-06-22T23:16:30.200Z","references":["https://osv.dev/vulnerability/PYSEC-2026-2300","https://access.redhat.com/security/cve/CVE-2026-41523","https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-41523.json","https://access.redhat.com/errata/RHSA-2026:36005","https://access.redhat.com/errata/RHSA-2026:36006","https://huntr.com/bounties/dcb05b04-e625-41e7-adbc-bbae0cc2d64c","https://bugzilla.redhat.com/show_bug.cgi?id=2491582","https://github.com/vllm-project/vllm/commit/b3c7ffcab82c2439726f8cb213800f6f38c023d3","https://github.com/vllm-project/vllm/security/advisories/GHSA-q8gq-377p-jq3r"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"PYSEC-2026-2300","url":"https://osv.dev/vulnerability/PYSEC-2026-2300"}],"summary":"vLLM is an inference and serving engine for large language models (LLMs). Prior to 0.22.0, an assert-based security check in vLLM's activation function loading allows any unauthenticated attacker to a"}