{"action":"Upgrade vllm to 0.22.0 or later.","affected":[{"fixed":"0.22.0","introduced":"0"}],"component":"vllm","cve_ids":["CVE-2026-47155"],"ecosystem":"PyPI","epss":0.00249,"exploited":false,"fixed_versions":["0.22.0"],"ghsa_id":"GHSA-3ww4-5jv9-j5gm","id":"tcs_01M5KGYN1RF7G5Z5Z9PAEEC67Z","modified_at":"2026-07-13T07:15:12.555153958Z","published_at":"2026-06-22T23:16:30.357Z","references":["https://osv.dev/vulnerability/PYSEC-2026-2301","https://github.com/vllm-project/vllm/security/advisories/GHSA-3ww4-5jv9-j5gm","https://huntr.com/bounties/3f1e24c0-87d2-4f6c-a705-820f380879ac","https://github.com/vllm-project/vllm/pull/42616","https://github.com/vllm-project/vllm/commit/d26a28ab033697f55a1414b5b0435de7cd6045b6"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"PYSEC-2026-2301","url":"https://osv.dev/vulnerability/PYSEC-2026-2301"}],"summary":"vLLM is an inference and serving engine for large language models (LLMs). Prior to 0.22.0, vLLM's revision pinning controls do not consistently apply to all artifacts loaded for a model. A deployment"}