{"action":"Upgrade keras to 3.14.0 or later.","affected":[{"fixed":"3.14.0","introduced":"0"}],"component":"keras","cve_ids":["CVE-2026-11816"],"ecosystem":"PyPI","epss":0.00563,"exploited":false,"fixed_versions":["3.14.0"],"ghsa_id":"GHSA-hqp4-2352-xf5r","id":"tcs_01M5KGYS5K352J6P4D86VSJC5T","modified_at":"2026-08-10T11:01:44.730654Z","published_at":"2026-06-11T14:16:26.557Z","references":["https://osv.dev/vulnerability/PYSEC-2026-2324","https://access.redhat.com/security/cve/CVE-2026-11816","https://bugzilla.redhat.com/show_bug.cgi?id=2487912","https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-11816.json","https://github.com/keras-team/keras/commit/2465b6657b02c8eed308759b7e800e295ae01888","https://huntr.com/bounties/a07e3983-7158-4419-af2b-38f1dea01a4f","https://github.com/advisories/GHSA-hqp4-2352-xf5r"],"severity":{"label":"high","score":8.1},"sources":[{"source":"osv","source_id":"PYSEC-2026-2324","url":"https://osv.dev/vulnerability/PYSEC-2026-2324"}],"summary":"Keras versions prior to 3.14.0 are vulnerable to a path traversal issue in the archive extraction utilities located in `keras/src/utils/file_utils.py`. The functions `filter_safe_tarinfos()` and `filt"}