{"action":"Upgrade fastmcp to 3.2.0 or later.","affected":[{"fixed":"3.2.0","introduced":"0"}],"component":"fastmcp","cve_ids":["CVE-2025-64340"],"ecosystem":"PyPI","epss":0.00735,"exploited":false,"fixed_versions":["3.2.0"],"ghsa_id":"GHSA-m8x7-r2rg-vh5g","id":"tcs_01M5KGZQ1BZ57N256VEVPSVG86","modified_at":"2026-07-13T16:31:55.161769253Z","published_at":"2026-07-13T14:36:46.084219Z","references":["https://osv.dev/vulnerability/PYSEC-2026-2475","https://github.com/PrefectHQ/fastmcp/security/advisories/GHSA-m8x7-r2rg-vh5g","https://github.com/jlowin/fastmcp/security/advisories/GHSA-m8x7-r2rg-vh5g","https://nvd.nist.gov/vuln/detail/CVE-2025-64340","https://github.com/PrefectHQ/fastmcp/pull/3522","https://github.com/PrefectHQ/fastmcp","https://pypi.org/project/fastmcp","https://github.com/advisories/GHSA-m8x7-r2rg-vh5g"],"severity":{"label":"medium","score":6.7},"sources":[{"source":"osv","source_id":"PYSEC-2026-2475","url":"https://osv.dev/vulnerability/PYSEC-2026-2475"}],"summary":"FastMCP has a Command Injection vulnerability - Gemini CLI"}