{"action":"Upgrade langchain-core to 0.3.85 or later.","affected":[{"fixed":"0.3.85","introduced":"0"},{"fixed":"1.3.3","introduced":"1.0.0"}],"component":"langchain-core","cve_ids":["CVE-2026-44843"],"ecosystem":"PyPI","epss":0.00406,"exploited":false,"fixed_versions":["0.3.85","1.3.3"],"ghsa_id":"GHSA-pjwx-r37v-7724","id":"tcs_01M5KH07GRRPE0W5A92Y9CYV59","modified_at":"2026-07-13T16:31:48.854154388Z","published_at":"2026-07-13T15:15:43.058361Z","references":["https://osv.dev/vulnerability/PYSEC-2026-2564","https://github.com/langchain-ai/langchain/security/advisories/GHSA-pjwx-r37v-7724","https://nvd.nist.gov/vuln/detail/CVE-2026-44843","https://github.com/langchain-ai/langchain","https://pypi.org/project/langchain-core","https://github.com/advisories/GHSA-pjwx-r37v-7724"],"severity":{"label":"high","score":8.2},"sources":[{"source":"osv","source_id":"PYSEC-2026-2564","url":"https://osv.dev/vulnerability/PYSEC-2026-2564"}],"summary":"LangChain vulnerable to unsafe deserialization of attacker-controlled objects through overly broad `load()` allowlists"}