{"action":"Upgrade apache-airflow-providers-apache-hive to 5.0.0 or later.","affected":[{"fixed":"5.0.0","introduced":"0"}],"component":"apache-airflow-providers-apache-hive","cve_ids":["CVE-2022-46421"],"ecosystem":"PyPI","epss":0.03286,"exploited":false,"fixed_versions":["5.0.0"],"ghsa_id":"GHSA-rc58-qr9j-cpgw","id":"tcs_01M5KH194ES0QFWT73BV0V8RQG","modified_at":"2026-07-01T20:22:48.459474Z","published_at":"2026-06-29T11:50:33.981448Z","references":["https://osv.dev/vulnerability/PYSEC-2026-274","https://nvd.nist.gov/vuln/detail/CVE-2022-46421","https://github.com/apache/airflow/pull/28101","https://github.com/apache/airflow","https://lists.apache.org/thread/09twdoyoybldlfj5gvk0qswtofh0rmp4","https://pypi.org/project/apache-airflow-providers-apache-hive","https://github.com/advisories/GHSA-rc58-qr9j-cpgw"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"PYSEC-2026-274","url":"https://osv.dev/vulnerability/PYSEC-2026-274"}],"summary":"Apache Airflow Hive Provider vulnerable to Command Injection"}