{"action":"Upgrade apache-airflow-providers-google to 8.10.0 or later.","affected":[{"fixed":"8.10.0","introduced":"0"}],"component":"apache-airflow-providers-google","cve_ids":["CVE-2023-25691"],"ecosystem":"PyPI","epss":0.01597,"exploited":false,"fixed_versions":["8.10.0"],"ghsa_id":"GHSA-8g23-2q5p-8866","id":"tcs_01M5KH1ESYVV18MNXXDZ8YTTE7","modified_at":"2026-07-01T20:22:48.512031Z","published_at":"2026-06-29T11:50:42.896100Z","references":["https://osv.dev/vulnerability/PYSEC-2026-277","https://nvd.nist.gov/vuln/detail/CVE-2023-25691","https://github.com/apache/airflow/pull/29497","https://github.com/apache/airflow","https://lists.apache.org/thread/zdr8ovfttbh7kj0lydgcw88tbt2nmkcy","https://pypi.org/project/apache-airflow-providers-google","https://github.com/advisories/GHSA-8g23-2q5p-8866"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"PYSEC-2026-277","url":"https://osv.dev/vulnerability/PYSEC-2026-277"}],"summary":"Apache Airflow Google Provider Improper Input Validation vulnerability"}