{"action":"Upgrade apache-airflow-providers-mongo to 4.0.0 or later.","affected":[{"fixed":"4.0.0","introduced":"0"}],"component":"apache-airflow-providers-mongo","cve_ids":["CVE-2024-25141"],"ecosystem":"PyPI","epss":0.00625,"exploited":false,"fixed_versions":["4.0.0"],"ghsa_id":"GHSA-x5pm-h33q-cjrw","id":"tcs_01M5KH1GTZ2G8RWH62HCZV73JR","modified_at":"2026-07-01T20:22:48.520271Z","published_at":"2026-06-29T11:50:40.389103Z","references":["https://osv.dev/vulnerability/PYSEC-2026-278","https://nvd.nist.gov/vuln/detail/CVE-2024-25141","https://github.com/apache/airflow/pull/37214","https://github.com/apache/airflow","https://lists.apache.org/thread/sqgbfqngjmn45ommmrgj7hvs7fgspsgm","http://www.openwall.com/lists/oss-security/2024/02/20/5","https://pypi.org/project/apache-airflow-providers-mongo","https://github.com/advisories/GHSA-x5pm-h33q-cjrw"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"PYSEC-2026-278","url":"https://osv.dev/vulnerability/PYSEC-2026-278"}],"summary":"Improper Certificate Validation in apache airflow mongo hook"}