{"action":"Upgrade changedetection-io to 0.54.8 or later.","affected":[{"fixed":"0.54.8","introduced":"0"}],"component":"changedetection-io","cve_ids":["CVE-2026-35490"],"ecosystem":"PyPI","epss":0.00536,"exploited":false,"fixed_versions":["0.54.8"],"ghsa_id":"GHSA-jmrh-xmgh-x9j4","id":"tcs_01M5KH1MMM99WHAX3A9M4DAR5X","modified_at":"2026-05-20T09:18:54.357492Z","published_at":"2026-04-07T16:16:27.317Z","references":["https://osv.dev/vulnerability/PYSEC-2026-28","https://github.com/dgtlmoon/changedetection.io/security/advisories/GHSA-jmrh-xmgh-x9j4"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"PYSEC-2026-28","url":"https://osv.dev/vulnerability/PYSEC-2026-28"}],"summary":"changedetection.io is a free open source web page change detection tool. Prior to 0.54.8, the @login_optionally_required decorator is placed before (outer to) @blueprint.route() instead of after it. I"}