{"action":"Upgrade pgadmin4 to 9.15 or later.","affected":[{"fixed":"9.15","introduced":"0"}],"component":"pgadmin4","cve_ids":["CVE-2026-7814"],"ecosystem":"PyPI","epss":0.00163,"exploited":false,"fixed_versions":["9.15"],"ghsa_id":"GHSA-6p2c-69cv-3fxq","id":"tcs_01M5KH21HFWMARE3AWKEZ212AN","modified_at":"2026-07-13T16:32:56.103923896Z","published_at":"2026-07-13T15:15:44.878387Z","references":["https://osv.dev/vulnerability/PYSEC-2026-2866","https://nvd.nist.gov/vuln/detail/CVE-2026-7814","https://github.com/pgadmin-org/pgadmin4/issues/9865","https://github.com/pgadmin-org/pgadmin4/pull/9865","https://github.com/pgadmin-org/pgadmin4","https://pypi.org/project/pgadmin4","https://github.com/advisories/GHSA-6p2c-69cv-3fxq"],"severity":{"label":"medium","score":4.8},"sources":[{"source":"osv","source_id":"PYSEC-2026-2866","url":"https://osv.dev/vulnerability/PYSEC-2026-2866"}],"summary":"pgAdmin 4: Stored cross-site scripting (XSS) vulnerability in Browser Tree and Explain Visualizer modules"}