{"action":"Upgrade poetry to 2.3.4 or later.","affected":[{"fixed":"2.3.4","introduced":"0"}],"component":"poetry","cve_ids":["CVE-2026-41140"],"ecosystem":"PyPI","epss":0.00294,"exploited":false,"fixed_versions":["2.3.4"],"ghsa_id":"GHSA-73h3-mf4w-8647","id":"tcs_01M5KH267MQB7NWWS99J8QJGES","modified_at":"2026-07-13T16:32:58.805584132Z","published_at":"2026-07-13T15:02:52.466566Z","references":["https://osv.dev/vulnerability/PYSEC-2026-2890","https://github.com/python-poetry/poetry/security/advisories/GHSA-73h3-mf4w-8647","https://nvd.nist.gov/vuln/detail/CVE-2026-41140","https://github.com/python-poetry/poetry","https://github.com/python-poetry/poetry/releases/tag/2.3.4","https://pypi.org/project/poetry","https://github.com/advisories/GHSA-73h3-mf4w-8647"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2026-2890","url":"https://osv.dev/vulnerability/PYSEC-2026-2890"}],"summary":"Poetry has Path Traversal in tar extraction on Python 3.10.0 - 3.10.12 and 3.11.0 - 3.11.4"}