{"action":"Upgrade tensorflow to 2.5.3 or later.","affected":[{"fixed":"2.5.3","introduced":"0"},{"fixed":"2.6.3","introduced":"2.6.0"},{"fixed":"2.7.1","introduced":"2.7.0"}],"component":"tensorflow","cve_ids":["CVE-2022-23591"],"ecosystem":"PyPI","epss":0.00795,"exploited":false,"fixed_versions":["2.5.3","2.6.3","2.7.1"],"ghsa_id":"GHSA-247x-2f9f-5wp7","id":"tcs_01M5KH3AYS5FKSGB2B02VPSEME","modified_at":"2026-07-13T16:43:43.501688441Z","published_at":"2026-07-09T16:49:40.499683Z","references":["https://osv.dev/vulnerability/PYSEC-2026-3084","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-247x-2f9f-5wp7","https://nvd.nist.gov/vuln/detail/CVE-2022-23591","https://github.com/tensorflow/tensorflow/commit/448a16182065bd08a202d9057dd8ca541e67996c","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2022-100.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2022-155.yaml","https://github.com/tensorflow/tensorflow","https://pypi.org/project/tensorflow","https://github.com/advisories/GHSA-247x-2f9f-5wp7"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"PYSEC-2026-3084","url":"https://osv.dev/vulnerability/PYSEC-2026-3084"}],"summary":"Stack overflow in TensorFlow"}