{"action":"Upgrade tensorflow to 2.7.2 or later.","affected":[{"fixed":"2.7.2","introduced":"0"},{"fixed":"2.8.1","introduced":"2.8.0"},{"fixed":"2.9.1","introduced":"2.9.0"}],"component":"tensorflow","cve_ids":["CVE-2022-36004"],"ecosystem":"PyPI","epss":0.00488,"exploited":false,"fixed_versions":["2.7.2","2.8.1","2.9.1"],"ghsa_id":"GHSA-mv8m-8x97-937q","id":"tcs_01M5KH43B82S94TQZY1PSRAT2G","modified_at":"2026-07-13T16:43:23.725018541Z","published_at":"2026-07-13T14:19:42.203013Z","references":["https://osv.dev/vulnerability/PYSEC-2026-3218","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-mv8m-8x97-937q","https://nvd.nist.gov/vuln/detail/CVE-2022-36004","https://github.com/tensorflow/tensorflow/commit/552bfced6ce4809db5f3ca305f60ff80dd40c5a3","https://github.com/tensorflow/tensorflow","https://github.com/tensorflow/tensorflow/releases/tag/v2.10.0","https://pypi.org/project/tensorflow","https://github.com/advisories/GHSA-mv8m-8x97-937q"],"severity":{"label":"medium","score":5.9},"sources":[{"source":"osv","source_id":"PYSEC-2026-3218","url":"https://osv.dev/vulnerability/PYSEC-2026-3218"}],"summary":"TensorFlow vulnerable to `CHECK` fail in `tf.random.gamma`"}