{"action":"Upgrade tensorflow to 2.5.3 or later.","affected":[{"fixed":"2.5.3","introduced":"0"},{"fixed":"2.6.3","introduced":"2.6.0"},{"fixed":"2.7.1","introduced":"2.7.0"}],"component":"tensorflow","cve_ids":["CVE-2022-23569"],"ecosystem":"PyPI","epss":0.00462,"exploited":false,"fixed_versions":["2.5.3","2.6.3","2.7.1"],"ghsa_id":"GHSA-qj5r-f9mv-rffh","id":"tcs_01M5KH45QG1T7GMBNH333THNVB","modified_at":"2026-07-13T16:43:22.336896510Z","published_at":"2026-07-09T16:49:41.323317Z","references":["https://osv.dev/vulnerability/PYSEC-2026-3230","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-qj5r-f9mv-rffh","https://nvd.nist.gov/vuln/detail/CVE-2022-23569","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2022-78.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2022-133.yaml","https://github.com/tensorflow/tensorflow","https://github.com/tensorflow/tensorflow/blob/master/tensorflow/security/advisory/tfsa-2021-198.md","https://pypi.org/project/tensorflow","https://github.com/advisories/GHSA-qj5r-f9mv-rffh"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"PYSEC-2026-3230","url":"https://osv.dev/vulnerability/PYSEC-2026-3230"}],"summary":"`CHECK`-fails when building invalid tensor shapes in Tensorflow"}