{"action":"Upgrade crawl4ai to 0.8.0 or later.","affected":[{"fixed":"0.8.0","introduced":"0"}],"component":"crawl4ai","cve_ids":["CVE-2026-26216"],"ecosystem":"PyPI","epss":0.06418,"exploited":false,"fixed_versions":["0.8.0"],"ghsa_id":"GHSA-5882-5rx9-xgxp","id":"tcs_01M5KH4HS689NKDCK66Q7THS3H","modified_at":"2026-05-20T09:18:55.751893Z","published_at":"2026-02-12T16:16:17.447Z","references":["https://osv.dev/vulnerability/PYSEC-2026-33","https://github.com/unclecode/crawl4ai/blob/main/docs/blog/release-v0.8.0.md","https://github.com/unclecode/crawl4ai/security/advisories/GHSA-5882-5rx9-xgxp","https://www.vulncheck.com/advisories/crawl4ai-docker-api-unauthenticated-remote-code-execution-via-hooks-parameter"],"severity":{"label":"critical","score":10},"sources":[{"source":"osv","source_id":"PYSEC-2026-33","url":"https://osv.dev/vulnerability/PYSEC-2026-33"}],"summary":"Crawl4AI versions prior to 0.8.0 contain a remote code execution vulnerability in the Docker API deployment. The /crawl endpoint accepts a hooks parameter containing Python code that is executed using"}