{"action":"Upgrade tensorflow-cpu to 2.7.2 or later.","affected":[{"fixed":"2.7.2","introduced":"0"},{"fixed":"2.8.1","introduced":"2.8.0"},{"fixed":"2.9.1","introduced":"2.9.0"}],"component":"tensorflow-cpu","cve_ids":["CVE-2022-35934"],"ecosystem":"PyPI","epss":0.00478,"exploited":false,"fixed_versions":["2.7.2","2.8.1","2.9.1"],"ghsa_id":"GHSA-f4w6-h4f5-wx45","id":"tcs_01M5KH4MV2PEYH2CXS6V3RRY6F","modified_at":"2026-07-13T16:43:52.767816384Z","published_at":"2026-07-09T16:49:52.473122Z","references":["https://osv.dev/vulnerability/PYSEC-2026-3316","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-f4w6-h4f5-wx45","https://nvd.nist.gov/vuln/detail/CVE-2022-35934","https://github.com/tensorflow/tensorflow/commit/61f0f9b94df8c0411f0ad0ecc2fec2d3f3c33555","https://github.com/tensorflow/tensorflow","https://github.com/tensorflow/tensorflow/releases/tag/v2.10.0","https://pypi.org/project/tensorflow-cpu","https://github.com/advisories/GHSA-f4w6-h4f5-wx45"],"severity":{"label":"medium","score":5.9},"sources":[{"source":"osv","source_id":"PYSEC-2026-3316","url":"https://osv.dev/vulnerability/PYSEC-2026-3316"}],"summary":"TensorFlow vulnerable to `CHECK` failure in tf.reshape via overflows"}