{"action":"Upgrade openssl-encrypt to 1.4.0 or later.","affected":[{"fixed":"1.4.0","introduced":"0"}],"component":"openssl-encrypt","cve_ids":["CVE-2026-74899"],"ecosystem":"PyPI","epss":0.0075,"exploited":false,"fixed_versions":["1.4.0"],"id":"tcs_01M5KH701S3AVKZCT50Y73VYAF","modified_at":"2026-08-29T09:10:52.207516742Z","published_at":"2026-08-17T11:16:44.917Z","references":["https://osv.dev/vulnerability/PYSEC-2026-3727","https://github.com/siyuan-note/siyuan/security/advisories/GHSA-43jx-gxq4-jpjc","https://www.vulncheck.com/advisories/openssl-encrypt-before-sandbox-escape-via-type-hierarchy","https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-m25m-ggxg-239c"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2026-3727","url":"https://osv.dev/vulnerability/PYSEC-2026-3727"}],"summary":"openssl_encrypt versions before 1.4.0 contain a sandbox escape vulnerability in IsolatedPluginExecutor that exposes Python type objects in restricted exec() builtins. Attackers can traverse the Python"}