{"action":"Upgrade openssl-encrypt to 1.4.0 or later.","affected":[{"fixed":"1.4.0","introduced":"0"}],"component":"openssl-encrypt","cve_ids":["CVE-2026-74872"],"ecosystem":"PyPI","epss":0.00679,"exploited":false,"fixed_versions":["1.4.0"],"ghsa_id":"GHSA-j48q-4c78-rhf9","id":"tcs_01M5KH72QK3YJCWETP4C9TN4HG","modified_at":"2026-09-01T09:15:03.518097029Z","published_at":"2026-08-17T11:16:41.560Z","references":["https://osv.dev/vulnerability/PYSEC-2026-3742","https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-j48q-4c78-rhf9","https://www.vulncheck.com/advisories/openssl-encrypt-before-arbitrary-code-execution-via-whirlpool"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"PYSEC-2026-3742","url":"https://osv.dev/vulnerability/PYSEC-2026-3742"},{"source":"nvd","source_id":"CVE-2026-74872","url":"https://nvd.nist.gov/vuln/detail/CVE-2026-74872"}],"summary":"openssl_encrypt versions before 1.4.0 contain an arbitrary code execution vulnerability in the Whirlpool hash implementation that uses broad glob patterns to load .so modules without integrity verific"}