{"action":"Upgrade openssl-encrypt to 1.4.0 or later.","affected":[{"fixed":"1.4.0","introduced":"0"}],"component":"openssl-encrypt","cve_ids":["CVE-2026-74882"],"ecosystem":"PyPI","epss":0.00167,"exploited":false,"fixed_versions":["1.4.0"],"ghsa_id":"GHSA-2592-7m3g-7fq6","id":"tcs_01M5KH7317W7B5MNFKSABMRRNY","modified_at":"2026-09-01T09:15:03.520237517Z","published_at":"2026-08-17T11:16:42.863Z","references":["https://osv.dev/vulnerability/PYSEC-2026-3744","https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-2592-7m3g-7fq6","https://www.vulncheck.com/advisories/openssl-encrypt-before-insecure-default-configuration"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"PYSEC-2026-3744","url":"https://osv.dev/vulnerability/PYSEC-2026-3744"}],"summary":"openssl_encrypt versions before 1.4.0 contain an insecure default configuration that trusts the entire RFC 1918 private address space in IntegrityProxyConfig trusted_proxies. Attackers on private netw"}