{"action":"Upgrade openssl-encrypt to 1.4.0 or later.","affected":[{"fixed":"1.4.0","introduced":"0"}],"component":"openssl-encrypt","cve_ids":["CVE-2026-74874"],"ecosystem":"PyPI","epss":0.00437,"exploited":false,"fixed_versions":["1.4.0"],"ghsa_id":"GHSA-vfgx-5q85-58q3","id":"tcs_01M5KH74VSSE1H52912AZXCTWT","modified_at":"2026-09-02T09:00:04.184109412Z","published_at":"2026-08-17T11:16:41.813Z","references":["https://osv.dev/vulnerability/PYSEC-2026-3754","https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-vfgx-5q85-58q3","https://www.vulncheck.com/advisories/openssl-encrypt-before-weak-prng-steganography-pixel-selection"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"PYSEC-2026-3754","url":"https://osv.dev/vulnerability/PYSEC-2026-3754"},{"source":"nvd","source_id":"CVE-2026-74874","url":"https://nvd.nist.gov/vuln/detail/CVE-2026-74874"}],"summary":"openssl_encrypt versions before 1.4.0 use Python's non-cryptographic random module for steganographic pixel selection in the generate_pseudorandom_sequence function. Attackers who know the password ca"}