{"action":"Upgrade openssl-encrypt to 1.4.0 or later.","affected":[{"fixed":"1.4.0","introduced":"0"}],"component":"openssl-encrypt","cve_ids":["CVE-2026-74876"],"ecosystem":"PyPI","epss":0.00348,"exploited":false,"fixed_versions":["1.4.0"],"ghsa_id":"GHSA-8h88-gxp3-j7pg","id":"tcs_01M5KH754X7MX23BX28E7BQ14S","modified_at":"2026-09-02T09:00:06.181817409Z","published_at":"2026-08-17T11:16:42.073Z","references":["https://osv.dev/vulnerability/PYSEC-2026-3756","https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-8h88-gxp3-j7pg","https://www.vulncheck.com/advisories/openssl-encrypt-before-unverified-key-bundle-encryption"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"PYSEC-2026-3756","url":"https://osv.dev/vulnerability/PYSEC-2026-3756"},{"source":"nvd","source_id":"CVE-2026-74876","url":"https://nvd.nist.gov/vuln/detail/CVE-2026-74876"}],"summary":"openssl_encrypt versions before 1.4.0 contain a vulnerability in PublicKeyBundle.from_dict() that creates key bundles from untrusted data without verifying signatures. Attackers can call from_dict() f"}